This project is read-only.

Invalid Column Name

Feb 28, 2010 at 11:39 PM

Hi all.

The populated error is Invalid column name '<The name of the column>'.  What i did is that i created a table with auditing enabled in my model and executed the install project that upgrades my database. Everything worked fine and as expected.

After i added to this table two more columns through the model, i changed the version number and generated it again. I can see that the upgrade sql script was generated and it looks right. Now when i run the install project i get the above error. After a little research i can see that it is caused by "__TR_Citizens__INSERT".

Any ideas?

Thank you.

 

Mar 1, 2010 at 1:43 PM

You are right. There was a small error in the audit table script. The trigger cannot be run because the new column for the table was not added to its audit (shadow) table. This is new functionality after all. This has been corrected and will be in the next version. Look for it this week.

Mar 1, 2010 at 4:02 PM
Edited Mar 1, 2010 at 4:02 PM

Great, will wait then. In the mean time i will disable auditing and continue with my testing.

Mar 8, 2010 at 1:35 PM

Please get the latest version and regenerate.