Trouble Importing An Existing Database

Aug 19, 2010 at 2:17 PM

I am having trouble importing an existing database.  I am using nHydrate 3.6.0.172, a local instance of SQLEXPRESS 2008 and the AdventureWorks database and Windows Authentication. 

In the Import wizard I fill in a Company Name "Test" and a Project Name "TestImport" click next,
then Server = .\SQLEXPRESS and Database = AdventureWorks and Windows Authentication is checked. 
I then click the Import button and a progress bar appears and almost gets to the end then I get an error "The connection information is invalid."

Microsoft SQL Server Management Studio works ok with the same connection info.

Any ideas?

Aug 19, 2010 at 2:26 PM
I should have gone that one step further and clicked the finish button after acknowleding the error dialog because the Import actually worked. I guess you should know about the error dialog anyway.
Coordinator
Aug 19, 2010 at 5:14 PM
This is an issue with custom types. There is a "Flag" type that is really a bit. These were not getting imported properly since they are not native types. The next version will have this resolved. The type will be imported as its native type. So the field of type "Flag" will be imported as field of type bit. This applies to all custom types. There will be a release this weekend.
Oct 26, 2010 at 12:58 PM

Apparently this is still an issue. I have downloaded and installed the latest version yet I too continue to get this error. Though it does the import of tables, not views or SP's, I don't see them in the pick list unless I click finish. I have made sure the user account was DBO and still no luck.

 

Ken

Oct 27, 2010 at 7:22 AM
Edited Oct 27, 2010 at 7:24 AM

I'd want to ask coordinator -  Is it the same problem that you helped me to decide by your Widgetsphere.Generator.dll - I was able to import my model. Discussion - [Uncathable Employee error] ? 

If it is so then  may be you/or i can send to  wakp  this dll  - until you will make new release

wakp    type your target mail box - may be it 'll help you

Oct 27, 2010 at 1:03 PM

Thank you xidius but this is no longer a problem for me.  I was only trying to import a database of substance to test nHydrate import features but I have no need of complex types at this time so I abandoned the test. 

Your offer may be of use to beruken. 

Oct 27, 2010 at 2:16 PM

Thanks all. Yes, if available I could test with a new dll.

Oct 28, 2010 at 5:12 AM

 i can give you that dll .... write your  target mail  box    ...... if still need of course :)

Coordinator
Nov 3, 2010 at 1:02 AM

xidius, please send a database or schema file to chrisd@nhydrate.org where import fails. We have been testing on dozens of databases in-house without issue. If you have a failure case please send it to me so this can be addressed. There has been a new version posted with more support for views and a few fixes.