This project is read-only.

Build process

Nov 19, 2010 at 9:37 AM

Hey,

Can you please briefly provide instructions about how to build the latest version? Is Wix 3.5 requiered?

Thx!

Nov 21, 2010 at 11:54 PM

You must have VS.NET 2008 wit SP1 installed. Also you must download the 2008 SDK as well. You can build the solution in this environment. You can builld all but the actual plug-in in 2010 as well, but the vscodetools project must be compiled in 2008 with SDK. This will not build the installers. You need WIX for this and I need to get the exact versions to install if you need this. If you build the 2008 solution on your box it will copy the files to the appropriate install folder in Program Files.

Nov 22, 2010 at 7:27 AM

Yea, this is the Problem. The version is 3.6.0.166. I used the latest 3.5 build of WIX.

I tryed to build the 2008 installer but VS throw an error:

<WixVariable Id="WixUICostingPopupOptOut" Value="1" Overridable="yes" /> is defiend 2 times in the Project.

 

Which Wix version i should use for this version?

 

Thx a lot.

 

Jan 3, 2011 at 2:09 AM

There have been some changes to the build files in the last month. If you install WIX 3.5 you should be able to run everything in the 2010 editor as long as you install the 2010 SDK from Microsoft. There is no longer a need for 2008.