This project is read-only.

EFDAL: generated files missing

Feb 23, 2011 at 11:23 PM

I added new entities to the wsgen file and regenerated the files, but it looks like that things goes wrong. For some reason the .generated files aint created in i.e. folder ContextIncludeTree, but als in other folders.

using the following libraries:

EF Data Access Layer 4.0.0.188

EF Data Access Layer Interfaces 4.0.0.186

I downloaded the MSI from the location you sent me by email, concerning the static data issue.



 

Feb 24, 2011 at 1:36 AM

Please open your generator library again and you will see EFDAL has changed. Press the Update All button to download the latest update. After you close and re-open VS.NET please let me know if you still have issues. Also show all files in your project to ensure there are no files on disk that are not part of your project. If files to be generated are already on disk but NOT part of the project, you will not see them appear in the project.

Feb 24, 2011 at 6:40 PM
Edited Feb 24, 2011 at 6:43 PM

When I open de generator library, I dont see changes of the Efdal. I cannot Update any if the installed libraries, see attached file 1. All files are included in the project, i rechecked it.

Dont know whether it is relevant but when I hit the "check updates" button. I get the message, see attached file 2.

 

file1: http://www.shannado.nl/1.jpg

file2: http://www.shannado.nl/2.jpg

Feb 24, 2011 at 6:53 PM

I am completely lost now.

Yesterday evening and night en this morning I had the problems described in the  start topic.  Now I retry it once more. And all works fine.

Feb 26, 2011 at 4:15 AM

 

There was some sort of mismatch between the generators and the common assembly that reflects on all of them. This was causing some weird issues. The new build fixes this. We have tested this on a clean machine and download generators and generated every project type. We no longer see this issue. Please follow these steps.

Uninstall what you have. 
Delete the Program Files/Widgetsphere folder
Download the latest version from CodePlex
When you open a model the library will show, from there download the generators you want.

I am so sorry but this is now a distributed install and we had a growing pain. The installed common assemblies must stay perfectly in sync with the version on which the generators are compiled (perhaps at some later date). Please try again.

Feb 27, 2011 at 12:16 AM

No Problem, you are doing a great job.

I did the actions you mentioned, it all works perfect now !