This project is read-only.

Generator Package Messed Up?

Feb 24, 2011 at 10:41 PM

I downloaded and installed the 2/17 version of nHydrate. I first tried to just run the installer, but got an error message that I needed to remove the prior installation via control panel (I don't recall seeing that message for the last couple of updates).

I went ahead and uninstalled via control panel and then installed the new version. When I opened VS2010 and checked nHydrate settings I got a message that several of the generators were out of date, so I downloaded the updated versions.

I then tried generating a project. The generator succeeded, but the solution would not compile. There were numerous errors about various properties being less accessible than the interfaces they were assigned to (I'm doing this from memory). There was also an error related to GetConnectionString() not being defined on the entity context class. When I went to check the class definition for that problem all I found was the partial class file -- there was no "generated" file for the entity context class. I checked "show all files" to ensure the generated file hadn't been excluded from the solution, but found nothing. The .generated file simply hadn't been generated.

I then checked nHydrate settings again. This time it told me I was using an out of date version of nHydrate -- yet the version it wants me to download,, is in fact the one I downloaded. I then checked the versions of the generator libraries, and they are all, even though I downloaded, installed and updated from Yet nothing in nHydrate settings indicates that I need to update the generator libraries. Nor is there a way to force a "re-download" of the generator libraries. Lastly, the version string displayed in the nHydate settings dialog box is

Something seems really messed up. I'll try to uninstall and re-install everything. Please advise what else I should do.

Feb 24, 2011 at 10:57 PM

Okay, I uninstalled, re-downloaded and re-installed. No joy. Same problem -- generation succeeds, but various .generated files are not created and I get a ton of the following kinds of errors when I build:

Error 1 Inconsistent accessibility: property type 'System.Data.Objects.IObjectSet<JumpForJoySoftware.T2T.EFDAL.Interfaces.Entity.ICountyInfo>' is less accessible than property 'JumpForJoySoftware.T2T.EFDAL.Interfaces.IT2TEntities.CountyInfo' E:\Programming\Trustee2Trustee\JumpForJoySoftware.T2T.EFDAL.Interfaces\IT2TEntities.Generated.cs 26 74 JumpForJoySoftware.T2T.EFDAL.Interfaces

As well as the interesting one:

Error 5 'JumpForJoySoftware.T2T.EFDAL.T2TEntities' does not contain a definition for 'GetConnectionString' E:\Programming\Trustee2Trustee\JumpForJoySoftware.T2T.EFDAL\Globals.Generated.cs 17 41 JumpForJoySoftware.T2T.EFDAL

which appears to be due to the entity context generated file not being generated.

By the way, this is all in an EFDAL project.

I am also still getting the funky error message urging me to upgrade to the version I already have installed ( from what the check update routine thinks I have installed ( Upon reflection, I think this is a separate, unrelated bug.

BTW, I have a couple of suggestions that I think the project team should implement regarding the code repository:

1) Tag the installer download file name with the version information (e.g., nHydrate- This would make it easier to keep older versions of nHydrate separate from newer ones, making temporary reversion easier when problems are encountered.

2) Add a "version archive" to the download page. Again, that way if a newly-released version has problems, it'll make it easier for someone to download and install an older version that, while it may have its own limitations, worked for the developer previously.

- Mark

Feb 24, 2011 at 11:07 PM

Another experiment: I created a new solution/project (an MVC3 C# project), added a new model file, created a table, gave it a column, and did an EFDAL generation. Same build errors, apparently due to the same problem -- missing generated files.

Feb 26, 2011 at 4:15 AM

There was some sort of mismatch between the generators and the common assembly that reflects on all of them. This was causing some weird issues. The new build fixes this. We have tested this on a clean machine and download generators and generated every project type. We no longer see this issue. Please follow these steps.

Uninstall what you have.
Delete the Program Files/Widgetsphere folder
Download the latest version from CodePlex
When you open a model the library will show, from there download the generators you want.

I am so sorry but this is now a distributed install and we had a growing pain. The installed common assemblies must stay perfectly in sync with the version on which the generators are compiled (perhaps at some later date). Please try again.

Feb 26, 2011 at 4:41 AM

No worries, and thanks for getting on the problem so quickly. I'll let you know how it goes.

Feb 26, 2011 at 4:54 AM

Okay, I'm back in business! Thanks!