addin Failed to load dialog

Oct 26, 2009 at 2:52 AM

Hello,

I installed nHydrate witnout any problem and then began going through the step-by-step document.  The model designer loaded without any problem the first time, and I registered.  I was then unsure if I had sucessfully registered as I was confused by the NHydrate Settings dialog.  I was not sure if it was asking for a key or not.  I restarted visual studio and started a new project thinking I might be asked to register again....  After creating the WSGEN file, VS prompted me that the addin failed to load along with some other information (unfortunatly I did not copy the information), however it did ask if I wanted to discontinue loading it in the future.  Thinking that this was only for this instance of visual studio I clicked YES...  Unfortunatly, It did not only mean this instance of VS.  Now, the addin does not load at all, ever.  The 4 items still show up in the tools menu, but the designer never shows up for a WSGEN file.  I have tried repairing nHydrate, re-installing nHydrate, repairing Visual Studio, re-installing Visual Studio, but nothing has helped.  I am running VS2008 SP1 on Windows 7.  I am unfortunatly not versed in the addin architecture for VS so I have not really been able to go much more that I described here.  Any help getting my install is appreciated.  This project looks very promising and I am excited to try it out.  I might suggest adding to the installer a process to reverse whatever setting VS sets when it disables the loading of a plugin... 

Thanks,

Dave

Oct 27, 2009 at 5:39 AM

same problem in here.. i tried to uninstall and install still the same.. can't open the wsgen editor.

Coordinator
Oct 27, 2009 at 12:12 PM

 

Please look at the following and tell me what you see.

The registry entries that identify where the wizard exists have failed to install

 

 

<Registry Root="HKLM" Key="Software\Microsoft\VisualStudio\9.0\Editors\{b25a3b08-df2f-44cf-965b-f71f1254c46b}" Value="VsCodeTools" Type="string">
<Registry Name="DisplayName" Value="#105" Type="string" />
<Registry Name="Package" Value="{e6bf88aa-2787-406b-9709-4eb75135b55e}" Type="string" />
</Registry>
<Registry Root="HKLM" Key="Software\Microsoft\VisualStudio\9.0\Editors\{b25a3b08-df2f-44cf-965b-f71f1254c46b}\Extensions">
<Registry Name="wsgen" Value="50" Type="integer" />
</Registry>
<Registry Root="HKLM" Key="Software\Microsoft\VisualStudio\9.0\Editors\{b25a3b08-df2f-44cf-965b-f71f1254c46b}\LogicalViews">
<Registry Name="{7651a703-06e5-11d1-8ebd-00a0c90f26ea}" />
</Registry>
<Registry Root="HKLM" Key="Software\Microsoft\VisualStudio\9.0\Projects\{2150e333-8fdc-42a3-9474-1a3956d46de8}\AddItemTemplates\TemplateDirs\{e6bf88aa-2787-406b-9709-4eb75135b55e}\/1" Value="#105" Type="string">
<Registry Name="TemplatesDir" Value="[Template]" Type="string" />
<Registry Name="SortPriority" Value="50" Type="integer" />
</Registry>

 

 

 

<Registry Root="HKLM" Key="Software\Microsoft\VisualStudio\9.0\Editors\{b25a3b08-df2f-44cf-965b-f71f1254c46b}" Value="VsCodeTools" Type="string">
	<Registry Name="DisplayName" Value="#105" Type="string" />
	<Registry Name="Package" Value="{e6bf88aa-2787-406b-9709-4eb75135b55e}" Type="string" />
</Registry>

<Registry Root="HKLM" Key="Software\Microsoft\VisualStudio\9.0\Editors\{b25a3b08-df2f-44cf-965b-f71f1254c46b}\Extensions">
	<Registry Name="wsgen" Value="50" Type="integer" />
</Registry>

<Registry Root="HKLM" Key="Software\Microsoft\VisualStudio\9.0\Editors\{b25a3b08-df2f-44cf-965b-f71f1254c46b}\LogicalViews">
	<Registry Name="{7651a703-06e5-11d1-8ebd-00a0c90f26ea}" />
</Registry>

<Registry Root="HKLM" Key="Software\Microsoft\VisualStudio\9.0\Projects\{2150e333-8fdc-42a3-9474-1a3956d46de8}\AddItemTemplates\TemplateDirs\{e6bf88aa-2787-406b-9709-4eb75135b55e}\/1" Value="#105" Type="string">
	<Registry Name="TemplatesDir" Value="[Template]" Type="string" />
	<Registry Name="SortPriority" Value="50" Type="integer" />
</Registry>

 

OR

 

The files failed to deploy to the Template Dir

VSCodeTools.vsdir, Model.vsz

 

OR

 

VSCodeTools2008.dll is not registered.

Can you please check these three options and telll me what you see

 

 

Oct 27, 2009 at 5:50 PM

It looks like all of my registry settings are there, and both VSCodeTools.vsdir and Model.vsz are in the template directory.

To make sure that the VSCodeTools2008.dll was registered I used: "regasm <path to VSCodeTools2008.dll>"

The model editor still does not show up in VS when selecting wsgen files.  

 

My guess is that is a visual studio setting that tells visual studio not to load the addin, (i.e. the addin has been black listed)

 

Hopefully this helps some.  If I figure out anything else I will post again....

 

Oct 27, 2009 at 9:59 PM

I think I got the solution to this prob,

There's a new update download and install it to your machine.
then go to  Visual Studio Command Promp
type this command denv /resetskippkgs

what I found out is that you have to create a new project solution.
then add your project as existing project.

hope this will help.

john 

Oct 27, 2009 at 10:08 PM

That solved the problem!!  Thanks!!