Invalid at the top level of the document

Oct 27, 2009 at 7:23 AM

When i try to create a model in the Model Files Category it gives me error

"Invalid at the top level of the document"

Pls. help

Thanks

John 

Coordinator
Oct 28, 2009 at 12:41 AM

please tell me your OS (xp, win7,etc) and vs.net version (from about box)

Oct 28, 2009 at 12:46 AM

OS: win7
vs: 2008sp1

Coordinator
Oct 28, 2009 at 2:15 AM

I am building a Win7 dev box VM right now.I forgot to ask about your language and regional settings. Please tell me so I can mimic this environment as closely as possible.

As a work around right click on the solution, choose add a new item, choose text file and name it something with a "wsgen" extension. This should create a blank model that you can use.

Oct 28, 2009 at 3:09 AM

Programming language you mean?

im using C#
and web environment 

Coordinator
Oct 28, 2009 at 10:50 PM

Nevermind. There is a new installation that does not have this issue. The new model is created a bit differently now. Please get the latest version and when you create a model a wizard is shown that walks you through importing a model from a database.

Coordinator
Nov 5, 2009 at 2:45 AM

We found that some non-US locales did have an issue loading the model. We have tested this on several machines with European settings and the models appear to create and load fine now.