Latest Update Crashing

May 13, 2011 at 3:45 PM

The May 9th update is gacking on me:

- I launch VS2010 in Administrator mode, but I get an error/warning message telling me that I don't have enough rights to run nHydrate

- Attempting to open the schema file results in the following exception:

System.Exception: E:\Programming\Trustee2TrusteeLinqInheritance\t2t.wsgen does not have the correct format. ---> System.TypeInitializationException: The type initializer for 'Widgetsphere.Generator.Common.GeneratorFramework.AddinAppData' threw an exception. ---> System.InvalidOperationException: There is an error in XML document (0, 0). ---> System.Xml.XmlException: Root element is missing.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Xml.XmlTextReaderImpl.Read()
   at System.Xml.XmlTextReader.Read()
   at System.Xml.XmlReader.MoveToContent()
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderAddinProperties.Read3_AddinProperties()
   --- End of inner exception stack trace ---
   at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
   at System.Xml.Serialization.XmlSerializer.Deserialize(TextReader textReader)
   at Widgetsphere.Generator.Common.GeneratorFramework.AddinAppData..ctor()
   at Widgetsphere.Generator.Common.GeneratorFramework.AddinAppData..cctor()
   --- End of inner exception stack trace ---
   at Widgetsphere.Generator.Common.GeneratorFramework.AddinAppData.get_Instance()
   at Widgetsphere.Generator.Common.GeneratorFramework.GeneratorHelper.OpenModel(String filePath, LoadResultConstants& loadResult)
   --- End of inner exception stack trace ---
   at Widgetsphere.Generator.Common.GeneratorFramework.GeneratorHelper.OpenModel(String filePath, LoadResultConstants& loadResult)
   at Widgetsphere.Generator.Common.Forms.ModelTree.LoadFile(String filePath)
   at Widgetsphere.Generator.ModelUI.ModelTreeEditor.Widgetsphere.Generator.Common.GeneratorFramework.IModelEditor.LoadFile(String fileName)
   at Widgetsphere.VsCodeTools.ModelViewer.Load(String pszFilename, UInt32 grfMode, Int32 fReadOnly)

However, downreving to the 5/2 release isn't solving the problem, so I'm not sure if this is on my end or in the application itself.

But I could really use some help... :)

- Mark

May 13, 2011 at 4:09 PM

Okay, the problem appears to have been on my end. To resolve things, I had to uninstall nHydrate, delete the Widgetsphere directory under Program Files, and delete all traces of nHydrate from the various folders under c:\users, and then reset the VS2010 addins by running devenv /resetaddin from a VS command prompt.

Oh, and then I of course rebooted :).

At that point I could install the 5/9 version.

- Mark