This project is read-only.

NHydrate Modeler 5.0 on Windows XP and Windows 7 with VS 2010 not working

Sep 20, 2012 at 5:18 PM

Hi,

I  have been trying to get NHydrate 5.1 working on XP/Windows 7/VS 2010

  but have had no success.

If I "add new item" and select the model project I get something that will read a database schema.

 

What I don't get is menu items to add entities and create relationships.

And the icons I see in the documentation are different form the one I see in life.

 

Has anyone got 5.1 installed correctly? Are there any prerequisites? IS there a more details "installation and setup" document? I have read the 2 that are in Codeplex already

Sep 21, 2012 at 7:29 PM

Please confirm that this is what you have done.

  • Create a console application
  • Add a new item "nHydrate" file (there is no model project)
  • Open the nHydrate Model file and you will be prompt for a company and project name
  • Once the designer is open, the toolbox has items you can drag onto the surface

Please confirm that your toolbox is empty as this would be a problem. Please send a screenshot or any other information of the problem to chrisd@nhydrate.org.

Sep 26, 2012 at 9:17 PM

Hi,

Is there any progress on this? Did you get my screenshots?

Sep 27, 2012 at 12:34 AM

On your screenshot you open the diagram file. This is supposed to be a file under the primary "nhydrate" file. You cannot open this. What do you see when you open the "nhydrate" file? There should be a designer.

Sep 27, 2012 at 11:01 PM

Hi,

I found the list of prerequisites here ,http://nhydrate.codeplex.com/wikipage?title=Compile%20Source%20Code&referringTitle=Documentation, and installed them. I can see the design surface now and can create entities

 

Thanks

Next week I'll try to create and gnerate code