This project is read-only.

NHydrate does not open NHydrate designer when open ".wsgen" file

Oct 8, 2009 at 5:17 AM

Hi,

I have just found this tool on CodeProject. I try to do through NorthWind example but when I created ".wsgen" file then I opened it, there is no NHydrate designer like document.

Kindly to guide me.

Cheers

Kim

Oct 8, 2009 at 5:15 PM

Most likely the install failed for some reason. Please go to Control Panel - > Programs and Features then uninstall nhydrate. After uninstalling nhydrate. Please rerun the NHydrate.msi file http://nhydrate.codeplex.com/Release/ProjectReleases.aspx?ReleaseId=33231#DownloadId=84244

Oct 14, 2009 at 12:17 AM

Also you should be able to add a new model from the menu. Right click on solution items | Add New Item. There is a "Model Files" category. This will add a new model to your solution. Please try the latest version.

Oct 21, 2009 at 4:41 PM

Try to run with admin account, possible permissions issue.

Oct 25, 2009 at 1:06 AM
Edited Oct 25, 2009 at 1:08 AM

We have found one thing that might cause this issue. If you do not have VS.NET Service Pack 1 installed, this might happen. There is a work around. Please see the following article.

http://nhydrate.codeplex.com/wikipage?title=Not%20Running%20SP1&referringTitle=Home

 

Oct 28, 2009 at 10:56 PM

There is a new installation that does not have this issue. The new model is created a bit differently now. Please get the latest version and when you create a model a wizard is shown that walks you through importing a model from a database. You should not see an error when you create a model anymore.

Nov 5, 2009 at 2:41 AM

We found that some non-US locales did have an issue loading the model. We have tested this on several machines with European settings and the models appear to create and load fine now.