WSGEN Designer not working

Dec 4, 2009 at 7:46 PM

Hey everybody,

After installing the MSI, i have tryed to make my first steps with nHydrate. After making a C# WinForms project I created a new text-item with the extension wsgen. After that I get the error Package Load Failure with the following error:: 

package 'Widgetsphere.VSCodeTools.VsCodeToolsPackage, VsCodeTools2008, Version=3.5.0.0, Culture=neutral,
PublicKeyToken=e6fa5c0e89df995e8' has failed to load properly (GUID = {E6BF88AA-2787-406B-9709-4EB75135B55E})
Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption.
Would you like to disable loading this package in the future? You may use 'denv /resetskippkgs' to re-enable package loading. 

I have Vista 32 Dutch with VS2008SP1.

Does somebody knows what is wrong?

 

Coordinator
Dec 5, 2009 at 12:18 AM

I am building a Vista32 machine with VS2008SP1 right now for testing; however would you uninstall, download the newest version again and reinstall. Make sure that VS.NET is not open while you are installing. I will try to install it on my test machine to your specs when done.

Dec 5, 2009 at 8:15 AM

I have uninstalled nHydrate, Solution Navigator, PowerCommands for VS2008. Reboot and then installed nHydrate-Complete.

Still the same failure pops up.

 

Other programs that are installed:

  • VS Developer and Database Edition TeamSuite
  • CrystalReports 2008
  • Infragistics 2009.2 WinForms
  • Expression 3
  • Office 2007
  • SQL server developer 2008
  • Windows Mobile 5.0 SDK 2
  • WPF Toolkit June 2009

I hope this information can help us for a solution. Maybe I can try something else?

 

Coordinator
Dec 5, 2009 at 11:24 PM

I did finally get a Vista32 machine built and there is an issue with loading the package. I cannot reproduce this in XP, Win7, Win2003, or Win2008; however it does occur on Vista. We are looking into it.

Coordinator
Dec 5, 2009 at 11:51 PM

I have new information. When I turned off UAC (user access control), there was no problem. This might be an issue because the tool does write to disk and it does access the registry to read its settings. We will look into this more but if you turn off UAC I think it might work for you. If you do not have UAC enabled please let me know.

Dec 6, 2009 at 2:45 PM

I have disabled the UAC and rebooted the PC. When doing the first steps, it gives me the following error:

System.Exception: C:\Users\Rob van Himste\AppData\Local\Temporary Projects\MynHydrate\TextFile1.wsgen does not have the correct format. ---> System.Xml.XmlException: Root element is missing.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Xml.XmlTextReaderImpl.Read()
   at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
   at System.Xml.XmlDocument.Load(XmlReader reader)
   at System.Xml.XmlDocument.Load(String filename)
   at Widgetsphere.Generator.Common.GeneratorFramework.GeneratorHelper.OpenModel(String filePath)
   --- End of inner exception stack trace ---
   at Widgetsphere.Generator.Common.GeneratorFramework.GeneratorHelper.OpenModel(String filePath)
   at Widgetsphere.Generator.Common.Forms.ModelTree.LoadFile(String filePath)
   at Widgetsphere.VsCodeTools.ModelTreeEditor.Load(String pszFilename, UInt32 grfMode, Int32 fReadOnly)

After OK the wsgen-file is "open" and gives the message: There are no designers visible at this time.

Any ideas?

Coordinator
Dec 6, 2009 at 8:44 PM

This is actually 2 issues. The UAC issue has been resolved by prompting the user about the situation. Your file issue is different. Please delete your WSGEN file and create a new one by selecting the solution in the project explorer, right-clicking and choose to add a new item. In the new item dialog highlight "Model" in the tree and choose the "Model" item. This will create a new model. Please download the newest version before you do this.

Dec 7, 2009 at 5:51 PM

Oke, that was the trick and not using a text-item.

Thanks for the support.